Activation of the environment to run the Use Case OMI/TROPOMI resolution comparison

Dear S&T,

I was trying to run the Use Case OMI/TROPOMI comparison in the PAL analysis environment and I followed the instructions about activating the avl environment. I can create the environment.yml, but when I run:

developer@workspace-analysis:~$ conda activate avl

I obtain this message:

developer@workspace-analysis:~$ conda activate avl

CommandNotFoundError: Your shell has not been properly configured to use 'conda activate'.
To initialize your shell, run

    $ conda init <SHELL_NAME>

Currently supported shells are:
  - bash
  - fish
  - tcsh
  - xonsh
  - zsh
  - powershell

See 'conda init --help' for more information and options.

IMPORTANT: You may need to close and restart your shell after running 'conda init'.

so then I tried to activate the bash and I got this other message:

developer@workspace-analysis:~$ conda init bash
no change     /opt/conda/condabin/conda
no change     /opt/conda/bin/conda
no change     /opt/conda/bin/conda-env
no change     /opt/conda/bin/activate
no change     /opt/conda/bin/deactivate
no change     /opt/conda/etc/profile.d/
no change     /opt/conda/etc/fish/conf.d/
no change     /opt/conda/shell/condabin/Conda.psm1
no change     /opt/conda/shell/condabin/conda-hook.ps1
no change     /opt/conda/lib/python3.10/site-packages/xontrib/conda.xsh
no change     /opt/conda/etc/profile.d/conda.csh
no change     /home/developer/.bashrc
No action taken.

Do you have an idea on how I can activate the environment and run the Notebook from the PAL analysis system? For now the Notebook fails at importing folium and geopandas.

Thank you!

Best regards,
Serena Di Pede

Dear Serena, this seems to be more a PAL specific issue (linked to how conda is installed/configured there). Since PAL is not a public service, nor covered by this forum, I will ask my colleagues that deal with PAL to respond to you offline about this specific problem.

Ok, thanks Sander! Sorry for the not pertinent question!