Atmospheric Toolbox

Error raised when using harp in xarray

I’m getting the following error when running the harp tool on xarray.

Traceback (most recent call last):
  File "2_process_netcdf_python.py", line 20, in <module>
    no2_l3 = harp.import_product(i,operations=harp_op)
  File "/cm/shared/apps/harp/1.13/lib/python3.8/site-packages/harp/_harppy.py", line 1217, in import_product
    raise CLibraryError()
harp._harppy.CLibraryError: syntax error, unexpected FUNC_KEEP, expecting $end

I ran the following command from the RUS Copernicus tutorial:

for i in file_names:
    print(i)
    no2_l3 = harp.import_product(i,operations=harp_op)
    export_filename = "{name}".format(name=i.replace('L2','L3'))
    harp.export_product(no2_l3,export_filename,file_format='netcdf')

Does anyone know why this is happening?

There is something wrong in your harp_op operations string.
Make sure to provide all important details (such as what operations you provide) if you ask for support.

Update: I was dividing the different operations with a slash (copying a RUS Copernicus tutorial). That was my error. It worked perfectly after I removed them. Thanks!