File not found error for cross sections dependent on analysis window and cross section values

Hey there,
I try to read in a white space seperated file as a cross section (XS) into QDOAS.

When my analysis window covers the entire wavelength range of the cross section, the file is found without problems.

However, if I select a lower bound of the analysis window larger than 305.645 nm (first wavelength were the XS is > 300), the reading in fails.

The issue seems to be related to the intensities: If I scale the XS values with factors <= 0.7 or >= 4, the file can be read in, while other factors lead to the same error:
grafik

The same problem occurs if I cut the XS to wavelengths >= 310 nm (ommiting the jump) and use a wavelength range starting at wavelengths >310 nm.

The cross section is a ring cross section multiplied with the wavelength, therefore the values are high compared to ‘normal’ cross sections.

Cross section files (as .txt) for different factors can be found at:

I tried the reading in with both the QDOAS versions 3.5.0 and 3.6.5.

Thanks for any help!
JoH

Hi, I just tried the cross section (with different scaling factors) in a test configuration, and I can’t reproduce the problem. Could you share a full configuration (qdoas configuration file, cross sections, reference and input file, the minimum required to reproduce the error), and the steps you take that produce this error (can be via private e-mail if you prefer not to make it public)? I assume the error shows up when you choose “Run Analysis”?

thank you!

Thomas

Hey again, I am afraid my email did not reach you. A short version of the .xml file can now also be found in the shared directory above.
The error does actually not occour when running the analysis. If I run the analysis, there are just no fits done without any error being thrown, usually. However, If I chose “View cross sections” for the anaysis, the message “Not found!!!” shows up next to the cross section path:

I hope that helps with reproducing.
Best,
JoH