How to install harp without using ./configure on Unix

I’m trying to install HARP on my works computer (Unix) but I do not have permission to do it. Indeed, when I tap the ./configure command on the terminal I have the following message: ./configure: Permission denied.
I tried using pip3 install --user harp but it wasn’t possible either. Is there a way to install harp manually?

In advance, thank you for the help!


I would recommend installing HARP in a conda environment.

Thank you for the answer, but conda is not installed on the server either. Actually, I work on the team server (connection via SSH) so not directly on the computer server, and permissions are not quite allowed. They’ve told me to try to install harp “manually”. Now i’m a bit stuck here. I want to regrid TROPOSIF data to compare with some assimilation outputs at the european scale.

As long as you can access the internet from this server, you should be able to install miniforge in your home directory. And then use this version of conda to create a local conda environment in which you install HARP.

Since HARP requires a few additional 3rd party packages, such as HDF4, HDF5, and CODA, using conda is likely still the fastest way to get HARP installed for you.

Sorry for my late response, but it finally worked as you said it, thank you so much Sander