Atmospheric Toolbox

How to install the harp package in Jupyter

Hi !
I use Anaconda on Windows to develop Jupyter notebooks using Python. I tried to install harp using conda from the command line

$ conda install -c stcorp harp

but the installation failed with the following message
“Solving environment: failed with initial frozen solve. Retrying with flexible solve”
and then it shows a long list of conflicts:

start list of conflicts ==============================================================
Package boost-cpp conflicts for:
libkml -> boost-cpp[version=’>=1.67.0,<1.67.1.0a0|>=1.68.0,<1.68.1.0a0|>=1.70.0,<1.70.1.0a0|>=1.72.0,<1.72.1.0a0|>=1.74.0,<1.74.1.0a0’]
libgdal -> libkml[version=’>=1.3.0,<1.4.0a0’] -> boost-cpp[version=’>=1.67.0,<1.67.1.0a0|>=1.68.0,<1.68.1.0a0|>=1.70.0,<1.70.1.0a0|>=1.72.0,<1.72.1.0a0|>=1.74.0,<1.74.1.0a0’]

Package cloudpickle conflicts for:
scikit-image -> cloudpickle[version=’>=0.2.1’]
scikit-image -> dask[version=’>=0.5’] -> cloudpickle[version=’>=0.2.2’]

Package tbb conflicts for:
tiledb -> tbb[version=‘2018.0.5.|2019.9.|>=2019.9|>=2018.0.5|>=2018.0.5,<2019.0a0’]
libgdal -> tiledb[version=’>=2.1.0,<2.2.0a0’] -> tbb[version=‘2018.0.5.|2019.9.|>=2019.9|>=2018.0.5|>=2018.0.5,<2019.0a0’]

Package libaec conflicts for:
tifffile -> imagecodecs -> libaec[version=’>=1.0.4,<2.0a0’]
imagecodecs -> libaec[version=’>=1.0.4,<2.0a0’]

Package toolz conflicts for:
scikit-image -> toolz[version=’>=0.7.3|>=0.7.4’]
scikit-image -> cytoolz[version=’>=0.7.3’] -> toolz[version=’>=0.10.0|>=0.8.0|>=0.8.2|>=0.7.2’]
cytoolz -> toolz[version=’>=0.10.0|>=0.8.0’]

Package sip conflicts for:
matplotlib==3.3.1 -> pyqt -> sip[version=‘4.18|4.18.|>=4.19.4,<=4.19.8|>=4.19.13,<=4.19.14’]
pyqt -> sip[version='4.18|4.18.
|>=4.19.4,<=4.19.8|>=4.19.13,<=4.19.14’]

Package zope conflicts for:
fiona -> attrs[version=’>=17’] -> zope
attrs -> zope

Package liblapacke conflicts for:
scipy -> blas=[build=mkl] -> liblapacke==3.8.0[build=‘4_mkl|5_mkl|7_mkl|8_mkl|9_mkl|13_mkl|14_mkl|20_mkl|19_mkl|18_mkl|16_mkl|15_mkl|12_mkl|11_mkl|10_mkl|6_mkl’]
scikit-learn -> blas=[build=mkl] -> liblapacke==3.8.0[build=‘4_mkl|5_mkl|7_mkl|8_mkl|9_mkl|13_mkl|14_mkl|20_mkl|19_mkl|18_mkl|16_mkl|15_mkl|12_mkl|11_mkl|10_mkl|6_mkl’]
numpy -> blas=[build=mkl] -> liblapacke==3.8.0[build=‘4_mkl|5_mkl|7_mkl|8_mkl|9_mkl|13_mkl|14_mkl|20_mkl|19_mkl|18_mkl|16_mkl|15_mkl|12_mkl|11_mkl|10_mkl|6_mkl’]

Package qt conflicts for:
pyqt -> qt[version=‘4.8.|5.6.|5.9.|>=5.12.5,<5.13.0a0|>=5.12.9,<5.13.0a0|>=5.9.7,<5.10.0a0|>=5.6.2,<5.7.0a0|>=5.9.6,<5.10.0a0|>=5.9.4,<5.10.0a0’]
matplotlib==3.3.1 -> pyqt -> qt[version='4.8.
|5.6.|5.9.|>=5.12.5,<5.13.0a0|>=5.12.9,<5.13.0a0|>=5.9.7,<5.10.0a0|>=5.6.2,<5.7.0a0|>=5.9.6,<5.10.0a0|>=5.9.4,<5.10.0a0’]

Package m2w64-expat conflicts for:
m2w64-xz -> m2w64-gettext -> m2w64-expat
m2w64-gettext -> m2w64-expat
Note that strict channel priority may have removed packages required for satisfiability.
end list of conflicts=============================================================

should I create a particular environment with specific packages in order to install harp ?
Best,
Luigi

Conda package dependencies can be complicated.

First, try not to mix the default conda channel with conda-forge. Either take everything from the default channel or everything from the conda-forge channel.
We very recently introduced an stcorp-forge channel with packages of CODA and HARP that are better compatible with conda-forge. You install this with e.g.:

conda install -c stcorp-forge -c conda-forge harp

Also, be very careful with installing packages using pip. If those are packages that are also available through conda channels, this will likely generate conflicts.

If all else fails, then creating a separate conda environment with just the packages that you need might be the best approach.

Also, I am not seeing anything in the conflict list that is linked to harp (or coda). Are you sure the environment you are trying to install harp in, is itself already consistent?

Hi Sander,

Thank you for your response. The stcorp-forge channel worked out perfectly.
Thanks a lot !

Luigi