Atmospheric Toolbox

Input and/or output product file not specified

Hello
I ran the command harpconvert -a “bin_spatial(1000,36,0.01,2000,26,0.01)” S5P_OFFL_L2__NO2____20190124T125722_20190124T143852_06642_01_010202_20190130T151234.nc outputE1.nc.

I viewed it on PANOLPLY.
I got results.

After that

harpconvert --format hdf5 --hdf5-compression 9 -a ‘tropospheric_NO2_column_number_density_validity>50;derive(datetime_stop {time})’ S5P_OFFL_L2__NO2____20200107T090747_20200107T104917_11577_01_010302_20200109T015137.nc grid_info.h5

It gives an error “input and/or output product file not specified” in my convert application.

Where am I doing wrong?

Thank you very much in advance for your help.

There is probably something wrong with the quotes used for your -a parameter. Make sure it is a proper single quote character (assuming you are not trying this on windows) and not some special version of a quote character.

1 Like

Thank you very much for your valuable help.

Your point is correct. Spelling error.
I fixed it but this time

ERROR: [HDF5] H5Pset_chunk(): all chunk dimensions must be less than 2^32 (major=“Invalid arguments to routine”, minor=“Out of range”) (…\src\H5Pdcpl.c:2027) ( grid_info.h5)

it gave this error.
I researched.
Download HDF5 conda install -c anaconda hdf5

I installed it with command.

but it didn’t fix it.

I am again with your support in the past.

harpconvert -a “keep(latitude_bounds,longitude_bounds,tropospheric_NO2_column_number_density);bin_spatial(1000, 36, 0.01, 2000,26, 0.01));squash(time, (latitude_bounds,longitude_bounds));derive(latitude {latitude});derive(longitude) {longitude});exclude(latitude_bounds,longitude_bounds,count,weight)” S5P_OFFL_L2__NO2____20200107T090747_20200107T104917_11577_01_010302_20200109T015137.nc o3grid.nc

I solved it with command.

I got my image.

Thank you very much for your interest.