Atmospheric Toolbox

Level 3 Aerosol Index gridded product

Dear Sander,

I have a problem when I try to process the Sentinel-5p Level 2 products to keep a single grid per orbit (level 3 – L3). I don’t understand how to define ingestion options using the -o parameter for example -o 'wavelength_ratio=354_338nm.

I have written the code below but something went wrong.

I will be very grateful if you could correct this error.

Best regards

The code is:

(base) PS C:> harpconvert -a ‘bin(); squash(time, (latitude,longitude))’ -o ‘wavelength_ratio=354_338 nm; -a ‘latitude > -55 [degree_north]; latitude < 60 [degree_north]; longitude > 18 [degree_east]; longitude < 25 [degree_east]; bin_spatial(180,-55,0.1,280,18,0.1); derive(latitude {latitude}); derive(longitude {longitude})’ \Users\Yosef\Desktop\July\AAI\Originol\S5P_OFFL_L2__AER_AI_20200708T084852_20200708T103022_14173_01_010302_20200709T223341.nc \Users\Yosef\Desktop\July\AAI\Processing\AII_8.nc

ERROR: syntax error: trailing characters after option value

Please check your command line options carefully. You can’t specify the -a option twice. And you are not closing the -o option properly.

You probably want something like:

harpconvert -o ‘wavelength_ratio=354_338nm’ -a ‘latitude > -55 [degree_north]; latitude < 60 [degree_north]; longitude > 18 [degree_east]; longitude < 25 [degree_east]; bin_spatial(180,-55,0.1,280,18,0.1); derive(latitude {latitude}); derive(longitude {longitude})’ -ap ‘bin(); squash(time, (latitude,longitude))’

But note that 354_338nm is already the default. You should use 340_380nm to get something else.