Reading TROPOSIF data, error while using harp.import_product


I’m working with TROPOSIF data, and I’m triying to regrid it to compare it with some outputs from an assimilation tool at the European scale. When I’m trying to import the data using harp I got the following error:

Note that these TROPOSIF data were downloaded from the noveltis website, which seems to be down now. These TROPOSIF data are constructed as the other S5P variables (SO2, NP, O3, …). In fact, just to try with another TROPOSIF data, I used the one available in STAC Browser which is SIF data from 2021, with no succes either on importing them with harp.
I already tried other exemples in the “Use Cases” and it worked out when using other S5P variables.
Hope anyone can help me with this little problem

Thanks in advance


The TROPOSIF products are not official S5P products and are currently not supported by HARP.
The official list can be found in the HARP documentation.

However, there is some good news.
First, a preliminary set of TROPOSIF products is currently available on the S5P-PAL Data Portal. This dataset will be back-processed to start of mission in the near future once all the new reprocessed RPRO collection 3 data has been ingested in the S5P-PAL system. This is probably going to be June or July (schedule is still to be discussed with ESA).
In parallel we are also working on implementing native ingestion support in HARP for all products that are provided by the S5P-PAL Data Portal. A version of HARP that supports this should arrive later this month.

Thank you so much for the answer and the information, I’ll stay tune for the new upcoming HARP releases