Atmospheric Toolbox

Visan: Import Harp does not work

I installed VISAN under Ubuntu 20.
I can start Visan without problem.
Whenever I start Harp import, the applciation just quit (the terminal displays killed)

I installed Visan using conda:
$ conda install -c stcorp visan
$ conda create -n visan
$ conda activate visan

Using conda I also installed:
$conda install -c conda-forge librsvg
$conda install numpy

Python is 3.7.10.
I thought the problem could come from my installation on Ubuntu 20 so I created another VM with Ubuntu 18. I still get the same behaviour.

Did I miss something in the installation?

You can’t combine the conda default channel and the conda-forge channel.

We are working on a stcorp-forge channel that has packages that are compatible with conda-forge, but this does not work with VISAN yet.

Also, each time you install packages in a conda environment, you have to include all channels again. Otherwise conda may change packages (e.g. from default channel to conda-forge or vice-versa), which will likely break packages in your installation.

Thanks for your reply.
If I understand correctly I should re-install visan without using the options “-c stcorp” and the option “-c conda’forge”. Is that correct?

No. You should still install visan with -c stcorp. But you should not install packages from conda-forge in the same environment.

Later, when we have visan working with conda-forge you would use -c stcorp-forge -c conda-forge if you want to combine visan with packages from conda-forge.

Thanks for the answer.
I started again the installation (with a brand new Ubuntu 20.04 VM) as follows:

  • installation of the python libraries: matplotlib, cartopy, imageio, pykdtree, scipy, numpy using the command conda install -c strcop library-name
  • installation of visan:
    $ conda create -n visan
    $ conda activate visan
    $ conda install -c stcorp visan

    .
    I also installed:
    $ sudo apt install libcanberra-gtk-module libcanberra-gtk3-module
    .
    Python 3.7.10 is correctly activated
    .
    When starting Visan, I get the following in the Visan window:
    VISAN 4.1 (Python 3.7.10, wxPython 4.0.4, VTK 8.2.0, NumPy 1.19.2, CODA 2.21.1, HARP 1.11)
    When I activate “harp-import”, i get (in the terminal) the message:
    Error loading theme icon ‘gtk-edit’ for stock: Unable to load image-loading module: /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: /lib/x86_64-linux-gnu/librsvg-2.so.2: undefined symbol: cairo_tag_end
    Killed
    ===
    I only found the library librsvg under source-forge. If I install it, visan exit without explanation with the message “Killed

Obviously, I am still missing an installation. Would you know?

On Linux you will have to make sure that you have X11 and Gtk-2.0 (including Glib-2.0, Pango, and ATK) installed, as well as OpenGL libraries.

Mind that VISAN requires OpenGL, so running VISAN in a VM may not be optimal. You would need the OpenGL Mesa library if you don’t have access to a 3D graphics card.

Thanks you for your response.
I went through all packages and tried to install them (I’m not a Linux expert so I searched on Internet commands to use for each of them).
Unfortunately, I still have the same behavior and a systematic crash.
I use a VM as my computer is used for my work and I shall not mix this environment with my working environment.

The whole idea of conda/anaconda environments is that you don’t have to mix environments. And that you can actually keep things separated. What OS are you using on your computer?

My environment (for the work) is MacOs.
My VM is Ubuntu 20,04 (I also tried Ubunt 18 with the same result)

Then I would highly recommend you install VISAN within the macOS environment.
You can install miniconda3 in your home directory and within there install VISAN.

I have this setup running myself.

Unfortunately, I use the Mac for my work (main activity) and unfortunately I cannot install Visan on it.
Should I consider another Linux Ubuntu version or another Linux?

Dear Support,
Many thanks for the support provided and the proposed solution.
Best regards
Yves