CODA unsupported product file for AEOLUS

Hi, I’m so sorry that I ask questions under very different issues!
I have tried to put the codadef file into my share/coda/definitions, but it doesn’t work.
It gives the same error:
coda_open(): unsupported product file

This is the code:
import coda
import os
from numpy import vstack,zeros
os.putenv(‘CODA_DEFINITION’, r’D:\yika\work\Aladin\coda\share\coda\definitions’)“AE_OPER_ALD_U_N_2B_20201008T233259_20201009T010347_0001.DBL”)
I wonder if there is someway to check why it’s wrong or how to deal with it?
Thanks again and sorry again!

Can you open a dos/command prompt and run codacheck on these product files?
e.g. codacheck -V AE_OPER_ALD_U_N_2B_20201008T233259_20201009T010347_0001.DBL, codacheck -V AE_OPER_ALD_U_N_2B_20201008T233259_20201009T010347_0001.HDR
And let me know the output?
The codacheck executable should be in D:\yika\work\Aladin\coda\bin.

It shows like:

That looks Ok.

I already see what is going on. You need to call the os.putenv before you call import coda:

import os
os.putenv(‘CODA_DEFINITION’, r’D:\yika\work\Aladin\coda\share\coda\definitions’)
import coda
from numpy import vstack,zeros“AE_OPER_ALD_U_N_2B_20201008T233259_20201009T010347_0001.DBL”)

This should work.

1 Like

It works!
Thank u!! This problem has troubled me one day!
thanks!!! :hugs:

hello sir. I also meet a similar problem.
I install coda 2.21.1 on the server via anaconda.
And try to run the sample program in github.
But it show me the error as yika64.
My error program as follows.

`import os

import coda from numpy import vstack, zeros


product =`

And i also try to use the codacheck to check out the DBL file,but it shows me that it is an unsupported product file.

I have placed the definition file in “/student/home/chikiangtam/anaconda3/envs/aelous/share/coda/definitions/”,and there are products/types/index.xml and tests.xml in the definition floder.
i wonder to know if some steps are still missing.
Thanks you very much!

You should not install the folder with xml files, but the .codadef file. You can find it as an attached for the release.

Thank you very much! i haved been solved the problem.
I dont know why the account “kktam” dose not have premission to reply, that i had to try to register a new account to reply to your answer.
Thank you again and wish you a happy life.

Thank you very much!this problem has been solved! :grinning: